LAMP环境下无法访问.php文件问题

由于最近需要学习一下php,所以在本机上尝试搭建干净的lamp环境。

在ubuntu16.04下安装MySQL、apache2、php7.0

sudo apt install  apache2

sudo apt install  php7.0

sudo apt install  mysql-server mysql-client

但是安装以后,写好的php文件,在浏览器访问的时候,php代码无法执行。

众里寻他千百度,百度了半天方法,都不大对。看到有个方法是安装apache2的php组件。

但是本机的是php7,只是把包的5换成7 ,发现无法支持。

所以利用一下命令

apt-cache search php

找到包libapache2-mod-php7.0 并安装。

看提示,发现安装libapache2-mod-php也是可以的(当然,我还没尝试)。

发表评论

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据